Epic Perfect World

Help with Paint Tool SAI?

Offline ☣EvilEye23☣

  • huh
  • hah
  • Characters: LightningI
I've been googling this for a bit, and since I haven't found any real "solutions", I'm just going to ask here as well.
There's this error that recently began to pop up for me in Paint Tool SAI.
It says, "Saving Canvas Failed", when I attempt to save it as .sai, .png, anything that isn't .psd.
It occurs after I open a .psd file in SAI, then I try and save the .sai file or other files.

:/ I know the way to avoid it is to just not open .psd files and if needed, save as .psd then open in another program, but I'm wondering if anyone knows a real fix to it.

C:
LightningI—150 wizard
⚔     ⚔     ⚔
  1 x  -  c a n a d a 

Offline Echo

  • VERY GRAPHIC
  • RIP
Mine does the same thing.
I saw something about deleting files fixing it but I don't know about that, could end up deleting something important.
People also mentioned upgrading to version 1.1.0 ( though it looks like that's the version I have ). I couldn't find any legit fixes otherwise
I don't usually open PSDs in SAI personally :c
Guides | RulesHelpdesk | Custom Stuff | tumblr
Aw
hi i'm cedes
Echo | Taunt | Nurse | Foam | Lunar

Quote from: Arashiwf
i remember the fashion

DJBFF

you should try to reinstall it.

Offline Xcution

  • avatar
  • Forum Veteran
  • I am the ocean of the Universe.
  • Characters: Xcution, Skyscream
  • Faction: IceLotus
Actually happens in many drawing softs as I noticed. Like Livebrush. Just dont open those files or search for program updates/fixes on the internet

Offline ☣EvilEye23☣

  • huh
  • hah
  • Characters: LightningI
Mine does the same thing.
I saw something about deleting files fixing it but I don't know about that, could end up deleting something important.
People also mentioned upgrading to version 1.1.0 ( though it looks like that's the version I have ). I couldn't find any legit fixes otherwise
I don't usually open PSDs in SAI personally :c
I see :< Mine actually didn't do that until just, like, yesterday. I saw something about deleting the files as well, I tried deleting one of them, but it didn't work. Deleting the registry entry I found when searhching for Paint Tool SAI didn't work for me either.
Also, I'm pretty sure there was something about saving it into another folder, but that may have been for another, different problem......
you should try to reinstall it.
can't really do that since it came from a zip, and I don't wanna lose brushes ><
LightningI—150 wizard
⚔     ⚔     ⚔
  1 x  -  c a n a d a