Epic Perfect World

Assassin 'Teleport' spells.

Offline Azzhole

  • avatar
  • The Hated
Shadow Jump and Shadow teleport for Assassin's would randomly work and then randomly not work. My husband has an Assassin as well and it happens to him a lot. At first I thought it was a lag issue but it turns out I hear it happens to quite a few other people that have told me the similar occurrences happen to them as well.



- I'm at Diabolic Shocktrooper ('Bubble boss') in F.C. before it spawns and the Elemento's are spawning in their usual pattern. As I attack them, I find no reason to walk from one side to the other of the boss to kill them so I use Shadow Jump. Sometimes I get stuck in place where I'm at and can't move at all after I do it. I would try and tap space bar and click around/use the movement keys to try and dislodge myself from where I'm at but I'm glitched in place. Though, I can still attack the Elemento that is where I teleported to. The only way I found to get out from being stuck is to wait for the cooldown to be finished or try and use Shadow Teleport on the opposite Elemento, not the one I'm at as it will still keep me stuck there. Even if I tried Shadow Teleport first, it would still get me stuck but only at random moments, not always. This is also not just for FC and that particular area. Sometimes when grinding, etc.

- Shadow Teleport is extremely odd, honestly. I can be gathering mobs or going 1 vs. 1 with anything, really and I'd target the appropriate mob(s) that would be a good idea to kill first so I decide,"Hey since I'll kill him first because he's annoying/tough, may as well stun him." So I cast Shadow Teleport. Bam, it would sometimes stun the target but not teleport me. So I'd have to run back to the stunned mob (which during the time I run back to him, my stun wore off anyway) and go to kill it. Keep in mind also that if I had gathered a group of mobs together, they're hitting me for a longer duration from me gathering them, stunning in a weird glitchy way, then running back to the specific mob I wanted to stun instead of just taking a bit of damage, killing the one I wanted to stun then kill the rest in an AoE mix, etc. And yes, it happens to Shadow Teleport too (Without the stun problem of course).

Not sure what else to add that might help but I tried to be detailed as possible so maybe something I'm doing/pattern of skills or something may need to change for it not to happen? I'm not sure but I hope I've supported enough detail as possible.

EDIT: Yes, I have tried Shadow Teleporting and Shadow Jumping without running before I casted it and running before I casted it. It's the same thing still.

Thanks for your time and hearing me out. :)
~Now hate me for stating my opinion that conflicts with yours~

Offline AOH

  • Old Player
  • Characters: Aids
  • Faction: Ŧα†αlι†y
Those skills have been glitchy like that as long as i can remember (on offical as well as here). Best advice i got for you is to try and remember where its most likly to happen and not use them there or exspect them to glitch.

Offline beardragon

  • avatar
  • Old Player
Yea, them skills always been glitchy. I know that in the Cube of Fate they're pretty much useless, and most of the times they're being glitchy is in instances. As for the Elementos at Shocktrooper, the glitch pattern is always the same: Teleporting from the front left to the back right will cause you to get stuck, teleporting from any on the right side to the one behind the boss won't work at all.

Also any teleportation skill from any class may cause you to get stuck at the place you teleported to, which seems to mainly be happening outside instances.

Offline Cortimi

  • avatar
  • Demon
The Seeker tele-stun has the exact same issues. In instances, I can sometimes stun something 30m away, but not tele. And on maps with any sort of uneven terrain (especially Morai), a lot of times I will get stuck in the ground in front of the mob, unable to move.
Cortimi - Demon Seeker
Cortimis - Demon Barbarian

Offline Lan

  • avatar
  • mmm bacon
  • Harshland Leader
Rawr.  Yes, I hate this issue.  The part where you tele stun and are still at the spot before you teleported and the mob is stunned.  OOOOR tele stun and are still at the spot before you teleported and the mob isn't stunned, but you still lost the spark.  Grrr..its aggravating.
I am.
Lan 150 Dem/Seeker           StelioKontos 150 Dem/BM
BloodKnife 150 Sage/Sin      Ashaman 150 Sage/Wiz
Aftershocks 150 Sage/Psy   Lion_O-150 Dem/Barb
Boba_Fett 150 Dem/Archer  More to come...

Offline Azzhole

  • avatar
  • The Hated
Ah, I see so it's on official as well? That's really weird because I have an Assassin on reg PWI and it's never happened to me ever. (Wow that sounded sarcastic but it really wasn't lol)

And yes, I've never played a Seeker before but I had no idea it happened on them too.

It's quite annoying though honestly but I guess we have to live with it lol.

Thanks for your replies everyone, I've also learned some new things. xD
~Now hate me for stating my opinion that conflicts with yours~

Offline Elly

  • Agony awaits
Actually, only times I've seen teleport skills not working is in frostcovered city (when you need to move from one to other platform, you can see a vague edge between those two), when teleporting to NPC's (every single NPC, seems like they are just not compatible with teleporting), and when teleport targets have higher altitude than current position. Teleporting to players and monsters always worked 100% for me.

Now, about getting stuck. You will get stuck only when teleporting to bishop on the right side and only on the bishops that come second out of those 3 series of bishops. Simple solution is just teleporting to another monster that will spawn next to that one. You really should be fine, there is always a target to teleport to.

Elly - 150 Sage venomancer
Decipher - 150 Demon mystic

[22:32:11] Chad: the name rev
[22:32:13] Chad: is foul language