Epic Perfect World

High Ping

Offline iams

  • avatar
  • Member
  • The Brilliant Smaxi
How can i fix the High Ping, everytime i Play, i always experience High Ping 1k-2k
I have

 Intel(R) Core(TM) i7 CPU       Q 740  @ 1.73GHz (8 CPUs), ~1.7GHz
NVIDIA GeForce GTX 460M
Memory: 8192MB RAM

and



DragonRush

Offline ☠EvilTouch☠

  • Retired Staff Member
  • Suns Wars Addict
  • DreamyTouch | we miss you papi♡
  • Characters: EvilTouch
  • Faction: Flower_Team
from the download speed i can easily say the problm would be your ethernet board. did u try updating it ?
did u try also unplugging the modem from the power ? sometimes it helps
also dont forget to clean cookies, temp files, etc....each 2 weeks or so...

Offline iams

  • avatar
  • Member
  • The Brilliant Smaxi
I did what you've said but still no luck
DragonRush

Offline ☠EvilTouch☠

  • Retired Staff Member
  • Suns Wars Addict
  • DreamyTouch | we miss you papi♡
  • Characters: EvilTouch
  • Faction: Flower_Team
try checking any programs installed like games ads or programs that u dont use...

i got no problems with the game  :rolleyes:

Offline beardragon

  • avatar
  • Old Player
Do another speed test but this time choose a location that's in the western part of Europe. Also you could do a trace route from your comp to the servers, this is gonna show where the problems are along the way.

Offline ☠EvilTouch☠

  • Retired Staff Member
  • Suns Wars Addict
  • DreamyTouch | we miss you papi♡
  • Characters: EvilTouch
  • Faction: Flower_Team
ping the EpicPW servers won't work, thats why we got protections  >:D

Offline beardragon

  • avatar
  • Old Player
ping the EpicPW servers won't work, thats why we got protections  >:D

PWI servers can't be pinged either but the traceroute is still displayed, the last 2-3 entries show "timed out". The whole point of the traceroute is to figure out the high latency someone is experiencing.