Epic Perfect World

the servers show " -- " in front of them

I already replaced the servers by Epic>Patcher>Server list.
I runned as a administrator + i verified the pather, still doesn't work.
Any tips?

~Fabio :-*

Online Eve

  • 。◕‿ ◕。
  • T❤
  • Characters: EViE
  • Faction: Artifex
have u considered setting it on fire?

Thankies Lacrimosa & Narcissism
for the beautiful art!

Offline Steroids

  • avatar
  • God of Noobs
  • Faction: Rawr
Restart your modem and try again.